Please enable javascript, or click here to visit my ecommerce web site powered by Shopify.
Jump to: navigation, search

Rockpi4/install/rockchip-flash-tools

    ROCK Pi 4 >  Install >  Install Rockchip Flashing tools

Install Rockchip flashing tools

ROCK Pi 4 supports maskrom mode, which is a special operation mode for CPU to wait for command from USB OTG port. The Linux/macOS PC tool we use to communicate with ROCK Pi 4 in maskrom mode are rkdeveloptool and RKDevTool. We use tool rkdeveloptool in Linux/macOS and RKDevTool tool under Windows.

Part one: RKDevTool on Windows

Step 1:Install RKDevTool

The tool is provided in a compressed package. First, download the compressed package of this tool, and click the download link (RKDevTool_Release_v2.81.zip). After downloading, unzip it. Installation step is completed.

Step 2:Install driver

Using the RK driver assistant tool to install the driver.

There’s no need to connect your Rockchip device during this procedure just download and extract RKDriverAssistant.zip

Then double click on DriverInstall.exe in the RKDriverAssistant directory to start the utility. If you installed the Rockchip USB drivers for any other Rockchip devices already, make sure you click “Uninstall Driver” first.

RK Driver Assistant Install Uninstall.jpg

Then click “Install Driver”to install the driver.

Part two: rkdeveloptool on Linux

For Linux, we build the latest rkdeveloptool (version >=1.32), from source code.

To build rkdeveloptool on a Debian based Linux distribution, follow the instruction below:

Install build dependency:

 sudo apt-get install libudev-dev libusb-1.0-0-dev dh-autoreconf

Clone the source code and build:

 git clone https://github.com/rockchip-linux/rkdeveloptool
 cd rkdeveloptool
 autoreconf -i
 ./configure
 make

If you encounter compile error like below

 ./configure: line 4269: syntax error near unexpected token `LIBUSB1,libusb-1.0'
 ./configure: line 4269: `PKG_CHECK_MODULES(LIBUSB1,libusb-1.0)'

You should install pkg-config libusb-1.0

 sudo apt-get install pkg-config libusb-1.0

Then re-run

 autoreconf -i
 ./configure
 make

Now you have rkdeveloptool executable at the current directory.

 sudo cp rkdeveloptool /usr/local/bin/
 sudo ldconfig

Make sure that its version is 1.32.or later

 rkdeveloptool -v
 rkdeveloptool ver 1.32

Part three: rkdeveloptool on macOS(Intel & Apple Silicon)

To build rkdeveloptool on macOS, you need homebrew(or similar package manager) to install required packages.

Install build dependency:

 brew install automake autoconf libusb

Clone the source code and build:

 git clone https://github.com/rockchip-linux/rkdeveloptool
 cd rkdeveloptool
 autoreconf -i
 ./configure
 make

If you encounter compile error like below

 ./configure: line 5384: syntax error near unexpected token `LIBUSB1,libusb-1.0'
 ./configure: line 5384: `PKG_CHECK_MODULES(LIBUSB1,libusb-1.0)'

You should install pkg-config libusb-1.0

 brew install pkg-config

Then re-run

 autoreconf -i
 ./configure
 make

Now you have rkdeveloptool executable at the current directory.

 sudo cp rkdeveloptool /opt/homebrew/bin/

Make sure that its version is 1.32 or later.

 rkdeveloptool -v
 rkdeveloptool ver 1.32